TecnoLabs

TecnoLabs es un programa que busca generar un espacio para el intercambio de conocimientos en temas como la programación, electrónica y robótica, está dirigido a niños, jóvenes y adolescentes, los cuales podrán programa crear, diseñar y construir mediante la utilización de herramientas de código libre.

Es la mezcla del lenguaje de programación y español que se emplea, dentro de la programación estructurada, para realizar el diseño de un programa. En esencial, el Pseudocódigo se puede definir como un lenguaje de especificaciones de algoritmos.

¿Para que sirve?

Sirve para escribir programas de computadora en lenguaje natural de tal manera que se facilite la comprensión, prueba y posterior codificación en un lenguaje de programación específico.

Condicionales en Pseint

Una instrucción de control condicional es un bloque de código que se ejecuta si cumple una condición, que nosotros pongamos. Esta condición es una expresión lógica que debe dar como resultado true o false, para ello es habitual usar los operadores relacionales y lógicos.

Las estructuras condicionales comparan una variable contra otro(s)valor (es), para que en base al resultado de esta comparación, se siga un curso de acción dentro del programa. Cabe mencionar que la comparación se puede hacer contra otra variable o contra una constante, según se necesite. DesarrolloWeb

Estructura Básica y Diagrama de Flujo

Estructura Condicional y Diagrama de Flujo

Estructura Ciclos y Diagrama de Flujo

Sesión 1

Operaciónes basicas.psc
Algoritmo ej_operaciones
    // Ejercicio que permita sumar dos números
    // Con los mismos números deben realizar la resta, multiplicación y división 
    
    suma=0;        //variable para realizar la suma
    resta=0;    //variable para realizar la resta
    mult=0;        //Variable para realizar la multiplicación
    div=0;        //Variable para realizar la división
    
    Escribir "Digite el primer número"; //mensaje
    Leer numero1; // variable para guardar el dato que el usuario ingresa
    Escribir "Digite el segundo número";
    Leer numero2;
    
    suma=(numero1+numero2);  //Con la variable creaada anteriormente se realiza la operación
    resta=(numero1-numero2);
    mult=(numero1*numero2);
    div=(numero1/numero2);
    
    Imprimir "El resultado de la suma es: ",suma;
    Imprimir "El resultado de la resta es: ",resta;
    Imprimir "El resultado de la multiplicación es: ",mult;
    Imprimir "El resultado de la división es: ",div;
    
FinAlgoritmo

datos.psc
Algoritmo datos
    // Crear algoritmo que pregunte nombres, apellidos, fecha 
    // nacimiento, edad,barrio e imprima el resultado.
    
    Escribir "Digite su nombre: ";     //mensaje
    Leer nombre;                    //variable para guardar el dato que el usuario ingresa
    Escribir "Digite su apellido: ";
    Leer apellido; 
    Escribir "Ingrese su fecha de nacimiento: ";
    Leer fecha;
    Escribir "Cuantos años tiene: ";
    Leer edad;
    Escribir "En que barrio vive: ";
    Leer barrio;
    
    Imprimir "Su nombre es: ", nombre;
    Imprimir "Su apellido es: ", apellido;
    Imprimir "La fecha de nacimiento es: ", fecha;
    Imprimir "Su edad es: ", edad;
    Imprimir "Usted vive en el barrio: ", barrio;
    
FinAlgoritmo

sumatoria.psc
Algoritmo ej_sumatoria
    // Ejercicio que me permita sumar tres números
    
    suma=0 // inicializo la varible en cero
    
    Escribir "Ingrese el primer número"; // mensaje
    Leer n1; // variable para guardar el dato que el usuario ingresa
    Escribir "Ingrese el segundo número";
    Leer n2;
    Escribir "Ingrese el tercer número";
    Leer n3;
    
    suma=(n1+n2+n3); // con esta variable se realiza la sumatoria 
    
    Imprimir "El resultado es: ",Suma; // se imprime el resultado
    
FinAlgoritmo

Sesión 2

tienda.psc
Algoritmo ejm_tienda
    // Algoritmo que permita elegir al usuario que alimento desea consumir, solo se tiene dos productos
    //Gaseosa
    g1=1000; // Se define la variable y se le asigna un valor
    g2=1200;
    g3=1400;
    // Papas
    p1=600; // Se define la variable y se le asigna un valor
    p2=800;
    p3=1000;
    
    vtotal=0 // Variable para realizar la suma de los productos
    
    Escribir "Que gaseosa desea: "; //mensaje
    Escribir "1. Manzana";         //corresponde a la variable g1
    Escribir "2. Coca Cola";    //corresponde a la variable g2
    Escribir "3. Malta";        //corresponde a la variable g3
    leer op1; // Esta variable permitirá guardar el "número" que el usuario ingreso
    // Condicional, se evalúa el dato que el usuario ingreso y lo compara con la condición para evaluar si se cumple o no.
    // si se cumple ingresa a las instrucciones, de no cumplirse pasara a evaluar la siguiente condición.
    Si op1=1 Entonces // Se evalúa si el dato que ingreso el usuario es igual a 1
        op1=g1; // Si se cumple la condición anterior, la variable "op1" se iguala al valor que contiene la variable "g1"
    SiNo //Si no se cumple la condición anterior, el algoritmo sigue evaluando las otras condiciónes
        Si op1=2 Entonces // Se evalúa si el dato que ingreso el usuario es igual a 2
            op1=g2 // Si se cumple la condición anterior, la variable "op1" se iguala al valor que contiene la variable "g2"
        SiNo
            Si op1=3 Entonces// Se evalúa si el dato que ingreso el usuario es igual a 3
                op1=g3  // Si se cumple la condición anterior, la variable "op1" se iguala al valor que contiene la variable "g3"
            Sino
                op1=0 //Si se ingresa un número diferente de 1,2 y 3 la variable se iguala a cero y aparece mensaje 
                Imprimir "El dato ingresado no es valido"
            FinSi
        FinSi
    FinSi

    Escribir "Que papitas desea: ";
    Escribir "1. Pollo";        //corresponde a la variable p1
    Escribir "2. Natural";        //corresponde a la variable p2
    Escribir "3. Limon";        //corresponde a la variable p3
    Leer op2; // Esta variable permitira guardar la respuesta del usuario para las papas
    Si op2=1 Entonces // Se evalúa si el dato que ingreso el usuario es igual a 1
        op2=p1;
    SiNo
        Si op2=2 Entonces // Se evalúa si el dato que ingreso el usuario es igual a 2
            op2=p2
        SiNo
            Si op2=3 Entonces // Se evalúa si el dato que ingreso el usuario es igual a 3
                op2=p3
            Sino
                op2=0 //Si se ingresa un número diferente de 1,2 y 3 la variable se iguala a cero y aparece mensaje 
                Imprimir "El dato ingresado no es válido"
            FinSi
            
        FinSi
    FinSi
    
    vtotal=(op1+op2) //Se suma el valor que contegan las dos variables para conocer el valor total
    
    Imprimir "El valor total es: ", vtotal //Se imprime el resultado total
    
FinAlgoritmo

notas.psc
Algoritmo cal_nota
    //Crear algoritmo que permita leer 4 notas de un estudiante y calcule si gano o perdió la materia, se gana con una nota superior o igual a 3
    
    snota=0 //Variable para calcular la nota final
    
    Escribir "Ingrese la nota 1: "; Leer n1; //Mensaje para ingresar la nota la cual se guarda en la variable n1
    Escribir "Ingrese la nota 2: "; Leer n2;
    Escribir "Ingrese la nota 3: "; Leer n3;
    Escribir "Ingrese la nota 4: "; Leer n4;
    
    snota=(n1+n2+n3+n4)/4 //Se realiza el cálculo para conocer la nota final
    
    Si snota>= 3 Entonces // Se evalua si la nota final es mayor o igual a 3
        Imprimir "La nota final es: ", snota, " gano la materia" //Si se cumple la condiciona imprime este mensaje
    SiNo //Si no cumple la condición, imprime el siguiente mensaja
        Imprimir "La nota final es: ", snota, " perdio la materia"
    FinSi
    
FinAlgoritmo


Sesión 3

calcular edad.psc
Algoritmo ej_edad
    // Hacer algoritmo que permita conocer la edad de una persona a partir de su fecha de nacimiento
    
    Escribir "Digite su fecha de nacimiento"; //Mensaje para el usuario
    Leer fecha; //Variable para almacenar el dato ingresado
    
    cal=(2017-fecha)  //Con la variable "cal" se halla la edad
    
    Imprimir "Usted tiene ", cal " años" //Se imprime el resultado
    
FinAlgoritmo

numero mod 2.psc
Algoritmo ej_mod
    // Calcular si un número es multiplo de 2
    // Se utiliza la variable mod = Módulo (resto de la división entera) 
    
    Escribir "Digite un número"; //Mensaje para el usuario
    Leer n1; //Variable para almacenar el dato ingresado
    
    Si(n1 mod 2 = 0) Entonces //Variable para evaluar si el residuo es igual a cero
        Imprimir "El número es multiplo de 2" //Si la condición se cumple imprime este mensaje
    sino 
        Imprimir "El número no es multiplo de 2"//Si no se cumple la condición imprime este mensaje
    FinSi
    
FinAlgoritmo

número.psc
Algoritmo ej_num
    // Algoritmo que me permita saber si un número es positivo, negativo o neutro
    
    Escribir "Digite un número";//Mensaje para el usuario
    Leer n1;//Variable para almacenar el dato ingresado
    
    Si (n1 > 0) Entonces//Condicional para evaluar si el número es positivo
        Imprimir "El número es positivo";
    SiNo
        Si (n1 < 0) Entonces //Condicional para evaluar si el número es negativo
            Imprimir "El número es negativo";
        SiNo
            Imprimir "El número es neutro";//Si el número no cumple las condiciónes anteriores, muestra este mesanje
        FinSi
    FinSi
    
FinAlgoritmo

sueldo.psc
Algoritmo ej_sueldo
    // Algoritmo que permita conocer el salario de una persona por semana
    // Si trabaja 48 horas se paga la hora a 3000
    // si trabaja menos de 48 horas se paga la hora a 2000
    //  Si trabaja mas de 48 horas, las horas adicionales se pagan a 5000
    
    
    Escribir "Ingrese las horas trabajadas";//Mensaje para el usuario
    Leer horat//Varuable para guardar el dato ingresado
    
    Si (horat = 48) Entonces //Condicional para evaluar si trabajo 48 horas
        sueldo=(horat*3000) //Variable para conocer el sueldo total
        Imprimir "Su sueldo es: ", sueldo //Mensaje con el valor 
    SiNo
        Si (horat < 48) Entonces //Condicional para evaluar si trabajo menos de 48 horas
            sueldo=(horat*2000) //Variable para conocer el sueldo total
            Imprimir "Su sueldo es: ", sueldo //Mensaje con el valor 
        SiNo
            Si (horat > 48) Entonces //Condicional para evaluar si trabajo mas de 48 horas
                h=(horat-48) //Variable para conocer cuantas horas extra trabajo 
                cal2=(48*3000) //Variable para conocer el sueldo de las primeras 48
                cal3=(h*5000) //Variable para conocer el valor de las horas extra
                sueldo2=(cal2+cal3) //Variable para calcular el sueldo total
                Imprimir "Su sueldo es: ", sueldo2 //Mensaje con el valor 
            FinSi
        FinSi
    FinSi
    
FinAlgoritmo